Messaging Outage
Incident Report for Digital Pharmacist
Resolved
This incident has been resolved.
Posted Aug 10, 2023 - 12:58 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 10, 2023 - 12:20 CDT
Investigating
We have identified the issue and are working to correct it.
Posted Aug 10, 2023 - 12:19 CDT
This incident affected: Inbox / Messaging.