Pharmacy Dashboard Experience - Login Issues
Incident Report for Digital Pharmacist
Resolved
This incident has been resolved.
Posted Aug 15, 2022 - 13:04 CDT
Investigating
We have received several reports from clients that they are experiencing an issue when logging into their Pharmacy Dashboard Experience. Our team is investigating and will provide an update on this situation as soon as possible.
Posted Aug 15, 2022 - 12:09 CDT
This incident affected: Pharmacy Dashboard and Inbox / Messaging.