Outbound Voice Degraded
Incident Report for Digital Pharmacist
Postmortem

After a planned deployment to attempt to increase the number of outbound calls our system can handle on a daily basis, we observed that outbound calls were failing at the network level. In looking through our SIP logs, we determined that our telephony provider was refusing to authorize our connections to our SIP trunk.

Upon contacting the telephony provider, we were informed that the SIP trunk we use for outbound calls had been suspended. The new code had led to a substantial increase in the number of calls that were being placed concurrently, and the volume of calls we had placed to a few specific customers' patients triggered an alert at the telephony provider. This alert was handled manually on the provider's side, and culminated with the suspension of our SIP trunk, but the suspension of the trunk was not communicated to Digital Pharmacist.

Posted 5 months ago. May 22, 2019 - 15:23 CDT

Resolved
Detected that the outbound voice calls in Denver were not being processed
Posted 5 months ago. May 22, 2019 - 08:05 CDT