Refills Processing Delays
Incident Report for Digital Pharmacist
Resolved
The refill processing actions to manage the increase in volume have proven effective. Thank you for your patience.
Posted May 20, 2020 - 14:43 CDT
Update
Corrective actions and resources applied to manage demand. We are continuing to monitor processing to ensure timely refills.
Posted May 20, 2020 - 10:39 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 20, 2020 - 10:34 CDT
Identified
Due to a significant increase in refills, our refill processing may appear slower than normal, we are taking corrective actions.
Posted May 20, 2020 - 10:20 CDT
This incident affected: Refill Processing.