Outage - Pharmacy Dashboard
Incident Report for Digital Pharmacist
Resolved
This incident has been resolved.
Posted Oct 09, 2023 - 17:58 CDT
Investigating
We are currently investigating this issue.
Posted Oct 09, 2023 - 14:49 CDT
This incident affected: IVR Services (NPE IVR) and Pharmacy Dashboard.