Pharmacy Dashboard Experience - Login Issues

Incident Report for Digital Pharmacist

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 17:29 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2026 - 14:47 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 22, 2026 - 14:28 CDT

Investigating

We have received several reports from clients that they are experiencing an issue when logging into their Pharmacy Dashboard Experience. Our team is investigating and will provide an update on this situation as soon as possible.
Posted Apr 22, 2026 - 14:19 CDT
This incident affected: Pharmacy Dashboard and Inbox / Messaging.