Refill Processing degraded
Incident Report for Digital Pharmacist
Resolved
This incident has been resolved.
Posted 22 days ago. Sep 27, 2019 - 06:25 CDT
Update
We are continuing to monitor for any further issues.
Posted 23 days ago. Sep 26, 2019 - 22:13 CDT
Monitoring
The issue is resolved, but we will continue to monitor for any changes.
Posted 23 days ago. Sep 26, 2019 - 22:13 CDT
Investigating
We are currently investigating this issue.
Posted 23 days ago. Sep 26, 2019 - 17:21 CDT
This incident affected: Refill Processing.