Degraded Performance - Refill Processing
Incident Report for Digital Pharmacist
Resolved
The issue has been resolved.
Posted Oct 20, 2020 - 08:45 CDT
Investigating
We are currently investigating this issue.
Posted Oct 15, 2020 - 10:02 CDT
This incident affected: Refill Processing.